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1 Introduction

1.1 Purpose and scope
This document describes the interfaces from and to the SWARM Data Quality Control (DQC) module.

The DQC is a SWARM PDGS module that performs rudimentary screening of products immediately
after production by the APF/PDF processing facilities. The DQC can also be used manually to screen
static Auxiliary Data Files and/or Data Products.

The DQC is the name of the SWARM specific configuration of the APPROVE (Application for Product
Verification) tool. For the remaining part of the document we will keep using the term DQC and only
use the term 'approve' when we refer to the binary executable of the tool.

The DQC is developed as part of the SWARM Mission Performance & Planning System (MPPF)
project.

This work is done under contract no 21883/08/I-OL.

Note: Header image source: ESA.
1.2 Bibliography

1.2.1 Applicable Documents

AD1 [CVQ-SoW] SOW SWARM Mission Performance & Planning System Implementation for ICM
(Instrument Calibration Monitoring) DVT (Data Validation Tool) and DQC (Data Quality
Control), SWAM-GSEG-EOPG-SW-08-0008, Issue 1/0, 9 June 2008

AD2 [GS-MASTER-ICD] SWARM Ground Segment Master ICD, SW-IC-ESA-IC-0117, Issue 1.6, 14
November 2011

AD3 [LO-PFS] SWARM LO Product Format, SWARM-GSEG-EOPG-05-001, Issue 1 revision 7, 13
January 2010

AD4 [LO-PROD] SWARM Level 0 Products, SW-IF-EAD-GS-00017, Issue 11, 2 July 2012

AD5 [L1B-PFS] SWARM Level 1b Product Definition, SW-RS-DSC-SY-0007, Issue 5.11, 1 March
2012

AD6 [ECCS-E-40B] ECSS-E-40 Part 1B; Space Engineering — Software, 28 November 2003

AD7 [ECCS-Q-80B] ECSS-Q-80; Space product assurance, 10 October 2003

AD8 [FMT-GDL] Earth Explorer Ground Segment File Format Standard, PE-TN-ESA-GS-0001, Issue
1.4, 13 June 2003

AD9 [FMT-TAIL] Tailoring of File Format Standard, SW-TN-ESA-GS-0074, Issue 1.5, August 2009

AD10 [PDS-IPF-ICD] PDS-IPF ICD Generic Interface Guidelines, SW-ID-ESA-GS-0001, Issue 2.0, 2
May 2007

AD11 [L1B-PROCINT] IPF Swarm L1b Processor Interfaces, SW-ID-GMV-GS-0001, Version 3.5, 30
April 2012

AD12 [CVQ-CCN-PHASE2] CCN for Phase 2 Swarm Mission performance & planning Facility
implementation (MMPF-CVQ), SWAM-GSEG-EOPG-CN-10-0015, Issue 1.0, 5 July 2010

AD13 [CEFI-TII-ICD] SWARM MPPF-CVQ CEFI-TII Calibration Data Processor ICD, ST-ESA-SWARM-
ICD-0003, Issue 1.3, 12 October 2011

AD14 [L2-PFS] Product specification for L2 Products and Auxiliary Products, SW-DS-DTU-GS-0001,
Rev 2EdB, 1330 JuhyAugust 2012

AD15 [CVQ-SOW3] SoW for SWARM MPPF-CVQ CCN 03, SWAM-GSEG-EOPG-SW-12-0021, issue
1.2, 14 June 2012

AD16 [L1A-PFS] SWARM Level 1a Product Definition, SW-ID-GMV-GS-0003, Issue 3.1, 30 April
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1.2.2 Reference Documents

RD1 [PDGS-ICD] SWARM Payload Data Ground Segment Overall ICD, SWAM-GSEG-EOPG-ID-08-
| 0019, Issue 1.48, 31 December2009]uly 2012
RD2 [DQC-SUM] DQC User Manual, ST-ESA-SWARM-SUM-0001, Issue 1.4, 12 October 2011
RD3 [CODA] Common Data Access toolbox. Documentation is available at
http://www.stcorp.nl/coda/doc/. Documentation of the CODA expression language as can be
used in the Test Expressions is also provided as html documentation in the DQC software
package.

1.3 List of Abbreviations

Abbreviation |Explanation

ADF Auxiliary Data File

APPROVE Application for Product Verification
BEAT Basic ENVISAT Atmospheric Toolbox
CODA Common Data Access

DQC Data Quality Control

ESA European Space Agency
HK/TM House-Keeping/Telemetry
HTML HyperText Mark-up Language
ICD Interface Control Document
IPF Instrument Processing Facility
LO Level-0

L1 Level-1

L2 Level-2

S&T Science and Technology B.V.
TBC To Be Confirmed

TBD To Be Determined

TBW To Be Written

TC Tele-command

™ Telemetry

XML Extensible Mark-up Language
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2 Communication Definition

2.1 Functional Interface Definition

The DQC is the name of the SWARM specific configuration of the APPROVE (Application for Product
Verification) tool. APPROVE is a single mission independent application that will be able to take a
product and a test definition file, perform a series of tests on the product, and produce a test report
for the screened product. A product can either be a single file or be split into separate header and
datablock files in which case a single test report will be produced with the results for the screening
of both the header and datablock file.

For the remaining part of the document we will keep using the term DQC and only use the term
'approve' when we refer to the binary executable of the tool.

The DQC performs three types of checks on a product:
e Standard consistency check: Structural check of the product and a read of all data.

e Configurable product specific tests: These are tests that work on a single file. The tests are
defined in a Test Definition File. By editing this xml-file, the user can define additional
product specific tests that are included into the test procedure when the approve utility is
run.

e Configurable consistency check across data block and header files: In case a product
consists of a data block file (.DBL) and header file (.HDR) then the Test Definition File can
optionally contain user defined tests to check consistency of specific values between the
data block and header file.

The DQC has two modi operandi:

e As an IPF processor: The DQC on the APF/PDF will be an IPF processor compliant with [PDS-
IPF-ICD]. This operation of the DQC will be referred to as 'DQC processor'.

e As a standalone executable: It will also be possible to run the DQC from the command line
to manually screen e.g. Auxiliary Data Files. This operation is similar to the DQC processor,
but without the IPF requirements. It is referred to as 'standalone DQC'.

211 DQC as an IPF processor

A DQC processor consists of a single task. The executable for this single task will be the 'approve’
application.

Within the scope of a job only a single product will be checked and only a single Test Report will be
produced. A product can consist of both a header and a data block file. In those cases, the DQC
should be provided the 'stem’' of the product (i.e. filename without extension) as parameter and the
DQC will then automatically first find the datablock file (by appending .DBL to the Stem filename)
and then also look for the header file in the same location and include the screening report for both
files in the Test Report.

The definition of the DQC processor will be made known to the processing platform (Management
Layer) by means of two configuration files: the Task Table file and the Workstation Configuration
file.

There will be a separate 'logical' DQC processor per satellite, which will support all product types for
that satellite. This means that there will be a separate Workstation Configuration file entry and Task
Table file per satellite. The executables for the DQC will be the same for each processor
configuration.

Science and Technology B.V.
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The Management Layer software will run the approve executable as the first and only task of the
DQC processor with the location of the Job Order file as command-line parameter. The approve
executable will take from this Job Order file the location of the product that has to be screened and
the location of the Test Definition file. Log messages will be written to stdout and stderr and will be
collected by the Management Layer. When the product screening is finished the approve executable
will generate a Test Report file together with a Product List and Product Report file.

Task 1
v '
Level 0/1/2 [ N\
Product i : Test Report
v :

—_
e

Test Definition | —i»
S :

i approve
v '

Product Format |—-» m
Definition

~— N

Job Order
et J

Task Table

Processing System (Management Layer)

Workstation I:I IPF framework related files

Configuration

Figure 1 DQC Processor Overview

21.2 DQC as a standalone application

The standalone DQC will be operated using command-line parameters. The approve executable will
take one or more product filenames (and optional additional options) and perform a validation on
these products. By default approve will only apply the build-in tests on the product files, but it is
possible through either an environment variable or via a command-line option to specify the
location of a Test Definition file that should be used. Test results and messages will be sent to
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standard output (stdout and stderr). It is also possible, using a command-line option, to generate a
Test Report (one for each product) like the DQC processor instead.

—
S

Level 0/1/2 or / \

ADF Product >

A 4

error messages

Test Definition
v
optional

> test results

approve

—
= —

Test Report

A 4

1
1
1
1
1
1
1
1
|
or '
1
1
1
1
1
1
1
1
1
1

A 4

command-line parameters

N /

Figure 2 DQC Standalone Overview

A product can consist of both a header and a data block file. If the standalone DQC does not have
to produce a Test Report, the screening will be performed on a file by file basis (i.e. the header file
will not be included with a check of a data block file, and no HDR/DBL cross-file checks will be
performed). If a Test Report is requested then the standalone DQC will also include a check of the
header file (and perform cross-file HDR/DBL checks) if a check of the data block file is performed.
The reverse is however not true (i.e. a check of the header file will only produce a report for the
header file).

2.2 Interface Details Summary

Table 1 Input and output interfaces of the DQC

Interface Description Relevancy Type
Input product file(s) |Product file(s) to be checked by the Processor, standalone |Input
DQC
Product Format A single file containing descriptions of |Processor, standalone |Input
Definition file the product format for each supported

product. This file is used by the data
access library of APPROVE.

Test Definition file A list of screening tests for each Processor, standalone |Input
product type

Test Report Contains the results of the product Processor, standalone |Output
screening as performed by the DQC
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Job Order Definition of tasks to be performed by |Processor Input
the processor including all
configuration input parameters

Command line Switches for configuring the function Standalone Input
parameters of the DQC

Environment Variables for configuring the function |Standalone Input
variables of the DQC

Logging The DQC will write log messages to Processor, standalone |Output

stdout and stderr

Exit Code Exit status of the DQC Processor, standalone |Output
Product List The Product List file will be an ASCII Processor Output

file containing the full filename of the
Test Report

Product Report The Product Report is a file containing |Processor Output
log messages in an XML format
Task Table Specifies the tasks that a processor is |Processor *
composed of and the input/output file
definitions
Workstation The Workstation Configuration file Processor *
Configuration file defines the full list of processors for an
IPF

* Note that the Task Table and Workstation Configuration files are inputs to the Management Layer
and not direct inputs to the DQC.
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3 Interface details

In this section we describe details for each relevant interface.

3.1 Input Product File

3.11

The input product file is the file to be checked by the DQC. The DQC will be able to screen the
product types as mentioned in the table below. For each product type a link is provided to the
document that defines its format.

Description

A product can be a single .EEF file or can be split into separate .HDR header and .DBL data block
files. The screening of the DQC will be product based. This means that the product screening of a
product that is stored in separate header and data block files will produce a single report for two
separate physical files.

If the File_Name_Type of the input product in the JobOrder file is STEM, then the DQC will try to
find both the .DBL file and .HDR file and include both files in the screening.

If the DQC is running in standalone mode and the DQC is presented a .DBL file and the DQC is
requested to product a Test Report file the DQC will also try to find the .HDR file in the same
location and include this in the screening (otherwise the single input file is screened).

3.1.2 Format
Table 2 Product types supported by DQC

Product Type Description Definition
ACCANOM_O0_ |Science Data, Standard measurement mode, Satellite A [LO-PFS], [LO-PROD]
ACCBNOM_0_ |Science Data, Standard measurement mode, Satellite B [LO-PFS], [LO-PROD]
ACCCNOM_0_ |Science Data, Standard measurement mode, Satellite C [LO-PFS], [LO-PROD]
ACCATESTO_ Science Data, Selftesting mode, Satellite A [LO-PFS], [LO-PROD]
ACCBTESTO_ Science Data, Selftesting mode, Satellite B [LO-PFS], [LO-PROD]
ACCCTESTO_ Science Data, Selftesting mode, Satellite C [LO-PFS], [LO-PROD]
ASMASCA_O_ |Scalar Mode Science Data, Satellite A [LO-PFS], [LO-PROD]
ASMBSCA_0O_ | Scalar Mode Science Data, Satellite B [LO-PFS], [LO-PROD]
ASMCSCA_0_ |Scalar Mode Science Data, Satellite C [LO-PFS], [LO-PROD]
ASMAVEC_0_ |Vector Mode Science Data, Satellite A [LO-PFS], [LO-PROD]
ASMBVEC_0_ |Vector Mode Science Data, Satellite B [LO-PFS], [LO-PROD]
ASMCVEC_O0_ | Vector Mode Science Data, Satellite C [LO-PFS], [LO-PROD]
ASMABUR_O_ | Burst Mode Science Data, Satellite A [LO-PFS], [LO-PROD]
ASMBBUR_0O_ |Burst Mode Science Data, Satellite B [LO-PFS], [LO-PROD]
ASMCBUR_O0_ | Burst Mode Science Data, Satellite C [LO-PFS], [LO-PROD]
ASMAMAG_0_ |SpectroMag Mode Science Data, Satellite A [LO-PFS], [LO-PROD]
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ASMBMAG_Q_ |SpectroMag Mode Science Data, Satellite B [LO-PFS], [LO-PROD]
ASMCMAG_0_ |SpectroMag Mode Science Data, Satellite C [LO-PFS], [LO-PROD]
ASMALAS_Q_ | SpectroLaser Mode Science Data, Satellite A [LO-PFS], [LO-PROD]
ASMBLAS_0_ | SpectroLaser Mode Science Data, Satellite B [LO-PFS], [LO-PROD]
ASMCLAS_0_ | SpectroLaser Mode Science Data, Satellite C [LO-PFS], [LO-PROD]
ASMAPOW_Q_ |SpectroPowerLaser Mode Science Data Rep, Satellite A [LO-PFS], [LO-PROD]
ASMBPOW_0_ |SpectroPowerLaser Mode Science Data Rep, Satellite B [LO-PFS], [LO-PROD]
ASMCPOW_Q_ |SpectroPowerLaser Mode Science Data Rep, Satellite C [LO-PFS], [LO-PROD]
GPSAOBS_0_ |GPS Observation Data, Satellite A [LO-PFS], [LO-PROD]
GPSBOBS_0_ | GPS Observation Data, Satellite B [LO-PFS], [LO-PROD]
GPSCOBS_0_ |GPS Observation Data, Satellite C [LO-PFS], [LO-PROD]
GPSANAV_0_ | GPS Navigation Data, Satellite A [LO-PFS], [LO-PROD]
GPSBNAV_0_ |GPS Navigation Data, Satellite B [LO-PFS], [LO-PROD]
GPSCNAV_0_ | GPS Navigation Data, Satellite C [LO-PFS], [LO-PROD]
GPSAGPS_0_ |GPS Low Frequency Data, Satellite A [LO-PFS], [LO-PROD]
GPSBGPS_0_ |GPS Low Frequency Data, Satellite B [LO-PFS], [LO-PROD]
GPSCGPS_0_ |GPS Low Frequency Data, Satellite C [LO-PFS], [LO-PROD]
GPSAAGN_0_ |AGC Status Data - Navigate, Satellite A [LO-PFS], [LO-PROD]
GPSBAGN_O_ |AGC Status Data - Navigate, Satellite B [LO-PFS], [LO-PROD]
GPSCAGN_0O_ |AGC Status Data - Navigate, Satellite C [LO-PFS], [LO-PROD]
GPSAAGS_0_ |AGC Status Data - Standby, Satellite A [LO-PFS], [LO-PROD]
GPSBAGS_0_ |AGC Status Data - Standby, Satellite B [LO-PFS], [LO-PROD]
GPSCAGS_0_ |AGC Status Data - Standby, Satellite C [LO-PFS], [LO-PROD]
GPSANOISO_ Noise Histogram Data, Standby, Satellite A [LO-PFS], [LO-PROD]
GPSBNOISO_ Noise Histogram Data, Standby, Satellite B [LO-PFS], [LO-PROD]
GPSCNOISO0_ Noise Histogram Data, Standby, Satellite C [LO-PFS], [LO-PROD]
EFIANOM_0_ EFI Normal Mode Data, Satellite A [LO-PFS], [LO-PROD]
EFIBNOM_0_ EFI Normal Mode Data, Satellite B [LO-PFS], [LO-PROD]
EFICNOM_0_ EFI Normal Mode Data, Satellite C [LO-PFS], [LO-PROD]
EFIALPC_O_ EFI LP-Calibration Mode Data, Satellite A [LO-PFS], [LO-PROD]
EFIBLPC_0_ EFI LP-Calibration Mode Data, Satellite B [LO-PFS], [LO-PROD]
EFICLPC_O_ EFI LP-Calibration Mode Data, Satellite C [LO-PFS], [LO-PROD]
EFIATIC_O_ EFI TII-Calibration Mode Data, Satellite A [LO-PFS], [LO-PROD]
EFIBTIC_O_ EFI TII-Calibration Mode Data, Satellite B [LO-PFS], [LO-PROD]
EFICTIC_O_ EFI TII-Calibration Mode Data, Satellite C [LO-PFS], [LO-PROD]
STRANOM_Q_ |STR Attitude Data, Nominal electronic, Satellite A [LO-PFS], [LO-PROD]
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STRBNOM_0_ |STR Attitude Data, Nominal electronic, Satellite B [LO-PFS], [LO-PROD]
STRCNOM_O0_ |STR Attitude Data, Nominal electronic, Satellite C [LO-PFS], [LO-PROD]
STRARED_O_ |STR Attitude Data, Redundant electronic, Satellite A [LO-PFS], [LO-PROD]
STRBRED_0O_ |STR Attitude Data, Redundant electronic, Satellite B [LO-PFS], [LO-PROD]
STRCRED_0O_ |STR Attitude Data, Redundant electronic, Satellite C [LO-PFS], [LO-PROD]
VFMANOM_O_ |VFM Science Data 50Hz, Satellite A [LO-PFS], [LO-PROD]
VFMBNOM_O0_ |VFM Science Data 50Hz, Satellite B [LO-PFS], [LO-PROD]
VFMCNOM_O0_ |VFM Science Data 50Hz, Satellite C [LO-PFS], [LO-PROD]
VFMAN10_0_ |VFM Science Data 10Hz, Satellite A [LO-PFS], [LO-PROD]
VFMBN10_0_ |VFM Science Data 10Hz, Satellite B [LO-PFS], [LO-PROD]
VFMCN10_0_ |VFM Science Data 10Hz, Satellite C [LO-PFS], [LO-PROD]
VFMAN_1_0_ |VFM Science Data 1Hz, Satellite A [LO-PFS], [LO-PROD]
VFMBN_1_0_ |VFM Science Data 1Hz, Satellite B [LO-PFS], [LO-PROD]
VFMCN_1_0_ |VFM Science Data 1Hz, Satellite C [LO-PFS], [LO-PROD]
HK_ANOM_O0_ |Auxiliary HK, Satellite A [LO-PFS], [LO-PROD]
HK_BNOM_0_ |Auxiliary HK, Satellite B [LO-PFS], [LO-PROD]
HK_CNOM_0_ | Auxiliary HK, Satellite C [LO-PFS], [LO-PROD]
ASMASCI_1A ASM scientific data, 1 Hz, Satellite A [L1A-PFS]
ASMBSCI_1A ASM scientific data, 1 Hz, Satellite B [L1A-PFS]
ASMCSCI_1A ASM scientific data, 1 Hz, Satellite C [L1A-PFS]
VFMASCI_1A VFM scientific data, 1 Hz, Satellite A [L1A-PFS]
VFMBSCI_1A VFM scientific data, 1 Hz, Satellite B [L1A-PFS]
VFMCSCI_1A VFM scientific data, 1 Hz, Satellite C [L1A-PFS]
STRASCI_1A STR scientific data, 1 Hz, Satellite A [L1A-PFS]
STRBSCI_1A STR scientific data, 1 Hz, Satellite B [L1A-PFS]
STRCSCI_1A STR scientific data, 1 Hz, Satellite C [L1A-PFS]
ACCASCI_1A ACC scientific data, 1 Hz, Satellite A [L1A-PFS]*
ACCBSCI_1A ACC scientific data, 1 Hz, Satellite B [L1A-PFS]*
ACCCSCI_1A ACC scientific data, 1 Hz, Satellite C [L1A-PFS]*
EFIA_LP_1A LP sweep mode data, 1/128 Hz, LP harmonic mode data, 2 |[L1A-PFS]*

Hz, Satellite A
EFIB_LP_1A LP sweep mode data, 1/128 Hz, LP harmonic mode data, 2 |[L1A-PFS]*

Hz, Satellite B
EFIC_LP_1A LP sweep mode data, 1/128 Hz, LP harmonic mode data, 2 |[L1A-PFS]*

Hz, Satellite C
EFIATII_1A TII data, 2 Hz, and 1 Hz (HK), Satellite A [L1A-PFS]
EFIBTII_1A TII data, 2 Hz, and 1 Hz (HK), Satellite B [L1A-PFS]
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EFICTII_1A TII data, 2 Hz, and 1 Hz (HK), Satellite C [L1A-PFS]

GPSANOM_1A |GPS data, 1Hz (MDR_GPS_LEO) and 0.8Hz [L1A-PFS]*
(MDR_GPS_GPS), Satellite A

GPSBNOM_1A |GPS data, 1Hz (MDR_GPS_LEO) and 0.8Hz [L1A-PFS]*
(MDR_GPS_GPS), Satellite B

GPSCNOM_1A |GPS data, 1Hz (MDR_GPS_LEO) and 0.8Hz [L1A-PFS]*
(MDR_GPS_GPS), Satellite C

HK_AAOCS1A |AOCS housekeeping data, 1 Hz (Mag_HK and Thru_HK) [L1A-PFS]*
and 1/32 Hz (Prop_HK), Satellite A

HK_BAOCS1A |AOCS housekeeping data, 1 Hz (Mag_HK and Thru_HK) [L1A-PFS]*
and 1/32 Hz (Prop_HK), Satellite B

HK_CAOCS1A |AOCS housekeeping data, 1 Hz (Mag_HK and Thru_HK) [L1A-PFS]*
and 1/32 Hz (Prop_HK), Satellite C

HK_ABUS_1A |BUS housekeeping data, 0.25 Hz, Satellite A [L1A-PFS]*

HK_BBUS_1A |BUS housekeeping data, 0.25 Hz, Satellite B [L1A-PFS]*

HK_CBUS_1A |BUS housekeeping data, 0.25 Hz, Satellite C [L1A-PFS]*

MAGA_HR_1B |Mag-H Satellite A [L1B-PFS]

MAGB_HR_1B |Mag-H Satellite B [L1B-PFS]

MAGC_HR_1B |Mag-H Satellite C [L1B-PFS]

MAGA_LR_1B Mag-L Satellite A [L1B-PFS]

MAGB_LR_1B |Mag-L Satellite B [L1B-PFS]

MAGC_LR_1B |Mag-L Satellite C [L1B-PFS]

MAGA_CA_1B |Mag-C Satellite A [L1B-PFS]

MAGB_CA_1B |Mag-C Satellite B [L1B-PFS]

MAGC_CA_1B |Mag-C Satellite C [L1B-PFS]

MAGAMAN_1B |Magnetic Calibration Manoeuvre report, Satellite A [L1B-PFS]

MAGBMAN_1B |Magnetic Calibration Manoeuvre report, Satellite B [L1B-PFS]

MAGCMAN_1B |Magnetic Calibration Manoeuvre report, Satellite C [L1B-PFS]

MAGAEUL_1B |Euler angle estimation of the CRF <- VFM transformation, |[L1B-PFS]
Satellite A

MAGBEUL_1B |Euler angle estimation of the CRF <- VFM transformation, |[L1B-PFS]
Satellite B

MAGCEUL_1B |Euler angle estimation of the CRF <- VFM transformation, |[L1B-PFS]
Satellite C

EFIA_PL_1B Plasma product, Satellite A [L1B-PFS]

EFIB_PL_1B Plasma product, Satellite B [L1B-PFS]

EFIC_PL_1B Plasma product, Satellite C [L1B-PFS]

LP_A_CA_1B Langmuir Probe offset calibration data, Satellite A [L1B-PFS]

LP_B_CA_1B Langmuir Probe offset calibration data, Satellite B [L1B-PFS]
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LP_C_CA_1B Langmuir Probe offset calibration data, Satellite C [L1B-PFS]
TIIA_CA_1B Thermal Ion Imager circular fit calibration data, Satellite A | [L1B-PFS]
TIIB_CA_1B Thermal Ion Imager circular fit calibration data, Satellite B | [L1B-PFS]
TIIC_CA_1B Thermal Ion Imager circular fit calibration data, Satellite C |[L1B-PFS]
MODA_SC_1B |Ephemeris product, Satellite A [L1B-PFS]
MODB_SC_1B |Ephemeris product, Satellite B [L1B-PFS]
MODC_SC_1B |Ephemeris product, Satellite C [L1B-PFS]
STRAATT_1B Attitude of S/C, 1Hz, Satellite A [L1B-PFS]
STRBATT_1B | Attitude of S/C, 1Hz, Satellite B [L1B-PFS]
STRCATT_1B Attitude of S/C, 1Hz, Satellite C [L1B-PFS]
GPSANAV_1B |On-board GPSR navigational solution - S/C position, 1Hz, |[L1B-PFS]
Satellite A
GPSBNAV_1B |On-board GPSR navigational solution - S/C position, 1Hz, |[L1B-PFS]
Satellite B
GPSCNAV_1B |On-board GPSR navigational solution - S/C position, 1Hz, |[L1B-PFS]
Satellite C
GPSA_RO_1B |RINEX Observation data, Satellite A [L1B-PFS]
GPSB_RO_1B |RINEX Observation data, Satellite B [L1B-PFS]
GPSC_RO_1B |RINEX Observation data, Satellite C [L1B-PFS]
GPSA_RN_1B |RINEX Navigation message, Satellite A [L1B-PFS]
GPSB_RN_1B RINEX Navigation message, Satellite B [L1B-PFS]
GPSC_RN_1B |RINEX Navigation message, Satellite C [L1B-PFS]
ACCA_PR_1B Acceleration product, Satellite A [L1B-PFS]
ACCB_PR_1B Acceleration product, Satellite B [L1B-PFS]
ACCC_PR_1B Acceleration product, Satellite C [L1B-PFS]
ASMAAUX_1B |Magnetic stray fields at ASM sensor position, Satellite A [L1B-PFS]
ASMBAUX_1B | Magnetic stray fields at ASM sensor position, Satellite B [L1B-PFS]
ASMCAUX_1B |Magnetic stray fields at ASM sensor position, Satellite C [L1B-PFS]
VFMAAUX_1B | Magnetic stray fields at VSM sensor position, Satellite A [L1B-PFS]
VFMBAUX_1B | Magnetic stray fields at VSM sensor position, Satellite B [L1B-PFS]
VFMCAUX_1B | Magnetic stray fields at VSM sensor position, Satellite C [L1B-PFS]
TIIA_DC_1B Product Report output from CEFI-TII, Satellite A [CEFI-TII-ICD]
TIIB_DC_1B Product Report output from CEFI-TII, Satellite B [CEFI-TII-ICD]
TIIC_DC_1B Product Report output from CEFI-TII, Satellite C [CEFI-TII-ICD]
MSW_EULi2C Euler angles for all satellites [L2-PFS]
MSW_VALi2C Intermediate validation report [L2-PFS]
MSW_EULi2D Euler angles for all satellites [L2-PFS]
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MSW_VALi2D Intermediate validation report [L2-PFS]
MCO_SHAi2C |Spherical harmonic model of the main (core) field and its |[L2-PFS]
temporal variation
MCO_VALi2C Intermediate validation report [L2-PFS]
MCO_SHAi2D |Spherical harmonic model of the main (core) field and its |[L2-PFS]
temporal variation
MCO_VALi2D Intermediate validation report [L2-PFS]
MLI_SHAi2C Spherical harmonic model of the lithospheric field [L2-PFS]
MLI_VALi2C Intermediate validation report [L2-PFS]
MLI_SHAIi2D Spherical harmonic model of the lithospheric field [L2-PFS]
MLI_VALi2D Intermediate validation report [L2-PFS]
MLI_SHAI2E Spherical harmonic model of the lithospheric field [L2-PFS]
MLI_VALIi2E Intermediate validation report [L2-PFS]
Q3D_CI_i2_ Q-matrix of 3D mantle conductivity including oceans [L2-PFS]
MIN_1DMi2_ 1D model of mantle conductivity [L2-PFS]
MI1_VALi2_ Intermediate validation report [L2-PFS]
MIN_3DMi2a 3D model of mantle conductivity (frequency domain) [L2-PFS]
MIN_3DMi2b 3D model of mantle conductivity (time domain) [L2-PFS]
MI3_VALi2_ Intermediate validation report [L2-PFS]
MCR_1DMi2_ 1D C-response [L2-PFS]
MC1_VALi2_ Intermediate validation report [L2-PFS]
MCR_3DMi2_ 3D C-response maps [L2-PFS]
MC3_VALi2_ Intermediate validation report [L2-PFS]
MMA_SHAI2C | Spherical harmonic model of the large-scale [L2-PFS]
magnetospheric field and its Earth-induced counterpart
MMA_VALi2C Intermediate validation report [L2-PFS]
MIO_SHAIi2C Spherical harmonic model of the daily geomagnetic [L2-PFS]
variation at middle latitudes (Sq and low latitudes — EEJ)
MIO_VALi2C Intermediate validation report [L2-PFS]
MIO_SHAIi2D Spherical harmonic model of the daily geomagnetic [L2-PFS]
variation at middle latitudes (Sq and low latitudes - EEJ)
MIO_VALi2D Intermediate validation report [L2-PFS]
MSW_EUL_2C |Euler angles describing transformation from STR-CRF to [L2-PFS]
VFM frame for satellites A, B, and C
MSW_EUL_2D |Euler angles describing transformation from STR-CRF to [L2-PFS]
VFM frame for satellites A, B, and C
MSW_VAL_2C |Validation report about Euler angles [L2-PFS]
MSW_VAL_2D |Validation report about Euler angles [L2-PFS]
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MSW_VAL_2_ |Validation report about Euler angles [L2-PFS]
MSW_EUL_2F |Euler angles describing transformation from STR-CRF to [L2-PFS]
VFM frame for satellites A, B, and C
MCO_SHA_2C |Spherical harmonic model of the main (core) field and its |[L2-PFS]
temporal variation
MCO_SHA_2D |Spherical harmonic model of the main (core) field and its |[L2-PFS]
temporal variation
MCO_VAL_2C |Validation report on core magnetic field [L2-PFS]
MCO_VAL_2D |Validation report on core magnetic field [L2-PFS]
MCO_VAL_2_ | Validation report on core magnetic field [L2-PFS]
MCO_SHA_2F |Spherical harmonic model of the main (core) field and its |[L2-PFS]
temporal variation
MLI_SHA_2C Spherical harmonic model of the lithospheric field [L2-PFS]
MLI_SHA_2D Spherical harmonic model of the lithospheric field [L2-PFS]
MLI_SHA_2E Extended spherical harmonic model of the lithospheric field | [L2-PFS]
MLI_VAL_2C Validation report on lithospheric field [L2-PFS]
MLI_VAL_2D Validation report on lithospheric field [L2-PFS]
MLI_VAL_2E Validation report on lithospheric field [L2-PFS]
MLI_VAL_2_ Validation report on lithospheric field [L2-PFS]
MIN_1DM_2_ 1D model of mantle conductivity [L2-PFS]
MIN_3DM_2a 3D model of mantle conductivity (frequency domain) [L2-PFS]
MIN_3DM_2b |3D model of mantle conductivity (time domain) [L2-PFS]
MCR_1DM_2_ | 1D C-response maps [L2-PFS]
MCR_3DM_2_ | 3D C-response maps [L2-PFS]
MI1_VAL_2_ Validation report on 1D mantle conductivity [L2-PFS]
MI3_VAL_2_ Validation report on 3D mantle conductivity [L2-PFS]
MC1_VAL_2_ Validation report on 1D C-response [L2-PFS]
MC3_VAL_2_ Validation report on 3D C-response [L2-PFS]
MMA_SHA_2C |Spherical harmonic model of the large-scale [L2-PFS]
magnetospheric field and its Earth-induced counterpart
MMA_VAL_2C |Validation report magnetospheric magnetic model [L2-PFS]
MMA_SHA_2F |Spherical harmonic model of the large-scale [L2-PFS]
magnetospheric field and its Earth-induced counterpart
MIO_SHA_2C |Spherical harmonic model of the daily geomagnetic [L2-PFS]
variation at middle latitudes (Sq and low latitudes — EEJ)
MIO_SHA_2D |Spherical harmonic model of the daily geomagnetic [L2-PFS]
variation at middle latitudes (Sq and low latitudes - EEJ)
MIO_VAL_2C Validation report on ionospheric magnetic model [L2-PFS]
MIO_VAL_2D Validation report on ionospheric magnetic model [L2-PFS]
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MIO_VAL 2 Validation report on ionospheric magnetic model [L2-PFS]

IBIATMS_2F Ionospheric bubble index [L2-PFS]

IBIBTMS_2F Ionospheric bubble index [L2-PFS]

IBICTMS_2F Ionospheric bubble index [L2-PFS]

TECATMS_2F Time series of the ionospheric total electron content [L2-PFS]

TECBTMS_2F Time series of the ionospheric total electron content [L2-PFS]

TECCTMS_2F |Time series of the ionospheric total electron content [L2-PFS]

FAC_TMS_2F Time series of field-aligned currents [L2-PFS]

FACATMS_2F Time series of field-aligned currents [L2-PFS]

FACBTMS_2F |Time series of field-aligned currents [L2-PFS]

FACCTMS_2F |Time series of field-aligned currents [L2-PFS]

EEFATMS_2F Equatorial Electric Field [L2-PFS]

EEFBTMS_2F Equatorial Electric Field [L2-PFS]

EEFCTMS_2F Equatorial Electric Field [L2-PFS]

SP3ACOM_2_ |Time series of position and velocity of the center of mass |[L2-PFS]
of each satellite (reduced-dynamic POD)

SP3BCOM_2_ |Time series of position and velocity of the center of mass |[L2-PFS]
of each satellite (reduced-dynamic POD)

SP3CCOM_2_ |Time series of position and velocity of the center of mass |[L2-PFS]
of each satellite (reduced-dynamic POD)

SP3AKIN_2_ Time series of position and velocity of the center of mass |[L2-PFS]
of each satellite (kinematic POD)

SP3BKIN_2_ Time series of position and velocity of the center of mass |[L2-PFS]
of each satellite (kinematic POD)

SP3CKIN_2_ Time series of position and velocity of the center of mass |[L2-PFS]
of each satellite (kinematic POD)

SP3AVAL_2_ Validation report for SP3ACOM_2_ [L2-PFS]

SP3BVAL_2_ Validation report for SP3BCOM_2_ [L2-PFS]

SP3CVAL_2_ Validation report for SP3CCOM_2_ [L2-PFS]

ACCACAL_2_ Accelerometer calibration parameters from the POD [L2-PFS]
process

ACCBCAL_2_ Accelerometer calibration parameters from the POD [L2-PFS]
process

ACCCCAL_2_ Accelerometer calibration parameters from the POD [L2-PFS]
process

ACCAPOD_2_ |Time series of non-gravitational accelerations estimated by | [L2-PFS]
POD

ACCBPOD_2_ | Time series of non-gravitational accelerations estimated by | [L2-PFS]
POD

ACCCPOD_2_ |Time series of non-gravitational accelerations estimated by | [L2-PFS]
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POD
ACCA_AE_2_ Time series of calibrated and pre-processed accelerometer |[L2-PFS]
observations and of aerodynamic accelerations from
satellite A
ACCB_AE_2_ |Time series of calibrated and pre-processed accelerometer |[L2-PFS]
observations and of aerodynamic accelerations from
satellite B
ACCC_AE_2_ Time series of calibrated and pre-processed accelerometer |[L2-PFS]
observations and of aerodynamic accelerations from
satellite C
DNSAWND_2_ | Time series of neutral thermospheric density and wind [L2-PFS]
speed
DNSBWND_2_ |Time series of neutral thermospheric density and wind [L2-PFS]
speed
DNSCWND_2_ |Time series of neutral thermospheric density and wind [L2-PFS]
speed
TDWAVAL_2_ |Validation report for DNSAWND_2_ [L2-PFS]
TDWBVAL_2_ |Validation report for DNSBWND_2_ [L2-PFS]
TDWCVAL_2_ | Validation report for DNSCWND_2_ [L2-PFS]
MAG_QL__ 2 |Quick Look of magnetic field products MAGx_LR_1B [L2-PFS]
EFI_QL__ 2 Quick Look of EFIx_PL_1B [L2-PFS]
REP__L2PS_ Report for each product release [L2-PFS]
AUX_KP__2_ Planetary index of geomagnetic activity [L2-PFS]
AUX_DST_2_  |Equivalent equatorial magnetic disturbances index [L2-PFS]
AUX_F10_2_ Index of daily solar radio flux [L2-PFS]
AUX_IMF_2_ Interplanetary magnetic field, 3-component magnetic field, | [L2-PFS]
solar wind density and velocity
AUX_KP__2F Planetary index of geomagnetic activity [L2-PFS]
AUX_DST_2F Equivalent equatorial magnetic disturbances index [L2-PFS]
AUX_F10_2F Index of daily solar radio flux [L2-PFS]
AUX_IMF_2F Interplanetary magnetic field, 3-component magnetic field |[L2-PFS]
AUX_SWV_2F |Solar wind density and velocity [L2-PFS]
AUX_IRZ_2F 12 month smoothed sunspot number [L2-PFS]
AUX_APX_2F Apex magnetic coordinates [L2-PFS]
AUX_GPSEPH GPS ephemeris [L2-PFS]
AUX_USLEAP Leap second information [L2-PFS]
AUX_DCB_2F |GPS satellite differential code biases [L2-PFS]
AUX_OBS_2_ | Geomagnetic observatory data; 3-component magnetic [L2-PFS]
field at INTERMAGNET and other magnetic observatories
AUX_IGR_2_ IGRF (International Geomagnetic Reference Field) latest [L2-PFS]
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generation, model of the Earth's core magnetic field

AUX_COR_2_ | Model for the core magnetic field [L2-PFS]

AUX_LIT_2_ Model for the lithospheric magnetic field [L2-PFS]

AUX_IGR_2F IGRF (International Geomagnetic Reference Field) latest [L2-PFS]
generation, model of the Earth's core magnetic field

AUX_COR_2F Model for the core magnetic field [L2-PFS]
AUX_LIT_2F Model for the lithospheric magnetic field [L2-PFS]
AUX_PMF_2F Magnetospheric model [L2-PFS]
AUX_PSM_2F |Coefficients to transform from Solar Magnetic (SM) to [L2-PFS]

geographic coordinates for computing the external
magnetic field

AUX_PGM_2F | Coefficients to transform from Geocentric Solar [L2-PFS]
Magnetospheric (GSM) to geographic coordinates for
computing the external magnetic field

AUX_MTI_2_ Model of magnetic signals of major tidal constituents [L2-PFS]

AUX_MCM_2_ | A priory radially-symmetric (1D) model of mantle [L2-PFS]
conductivity

AUX_OCM_2_ | 2D model of surface conductance [L2-PFS]

Note that for L2 products only L2 CAT-2 products (which are IBIXTMS_2F, TECXTMS_2F,

FAC_TMS_2F, FACXTMS_2F, and EEFXTMS_2F) are supported by the DQC in processor mode. The

other L2 products (CAT-1 and Auxiliary) are only supported by the DQC in standalone mode. This
\ means that L2 CAT-1 and Auxiliary products are not included in the DQC Task Table files.

L1A products are only supported by the DQC in standalone mode and not in processor mode. So the
L1A products are not included in the DQC Task Table files either.

* These L1A products are compliant with issue 3.1 of the product format specification plus the
corrections proposed in GMV SWARM_L1B_OP RIDs SW_CDR3_0OSAT_21 - SW_CDR3_0OSAT_33.
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3.2 Product Format Definition file

3.2.1 Description

The Product Format Definition file is a private configuration file of the DQC. It contains a description
of the product format for each supported product and this is used by the data access component,
the CODA (Common Data Access) library, of APPROVE to access and structurally verify a product.

There will only be one Product Format Definition file and it is provided as part of the DQC software
package. The file does not fall under configuration control of the PDGS and the filename and
contents are therefore not regulated by [FMT-GDL].

The filename of the file will be:
SWARM-<last modification date>.codadef

Where last modification date is the date in YYYYMMDD format of the last modification to the format
definitions.

3.2.2 Format

The .codadef file is a zip file containing xml files that describe the format of the supported SWARM
products.

3.3 Test Definition Files

3.3.1 Description

The Test Definition file contains a list of screening tests for each product type that is supported by
the DQC. The file is in XML format and follows [FMT-GDL]. The product type of the Test Definition
file is AUX_PAR_QC.

There will be one Test Definition file. The Test Definition file will contain test definitions for all
product types that are supported by the DQC.

The filename of the Test Definition file will be:

SW <file class> AUX PAR QC <validity start time> <validity stop time> <version
number>.EEF

The file class can be any sequence of 4 characters.

As a default, the OPER file class is used for the operational Test Definition file and TEST for special
Test Definition files that are used to verify the correctness of the DQC.

The validity start time is the start time of the period for which the file is applicable in
yyyymmddThhmmss format. The validity stop time is the stop time of the applicability period. Since
there is no real applicable date for the Test Definition file content the validity period will be set to
00000000T000000_99999999T999999 in line with [FMT-TAILL].

Mind that a Test Definition file should not be modified after it has been created. Only new Test
Definition files may be created.
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The version number of the Test Definition file is included as a 4 digit number in the filename and
guarantees that the file has a unique name. The first version number is 0001 and each time a new
version of the Test Definition file is created the version number should be increased by 1. Each file
class will have a different version numbering scheme. For example, you can have both version 0001
for OPER and version 0001 for TEST and these will refer to different Test Definition files.

An example of a real filename is:
SW_OPER_AUX_ PAR QC 00000000T000000 99999999T999999 0001 .EEF

3.3.2 Format
Table 3 Test Definition file
Tag name Type Attributes Description
Earth_Explorer_File structure See Earth_Explorer_File definition

Table 4 Earth_Explorer_File

Tag name Type Attributes Description
Earth_Explorer_Header |structure See Earth_Explorer_Header definition
Data_Block structure type="xml" See Data_Block definition

Table 5 Earth_Explorer_Header

Tag name Type Attributes Description
Fixed_Header structure See Fixed_Header definition
Variable_Header structure See Variable_Header definition

Table 6 Fixed_Header

Tag name Type Attributes Description

File_Name string Format:
"SW_cccc_AUX_PAR_QC_yyyymmddThhm
mss_yyyymmddThhmmss_vvvv"

File_Description string Value: "DQC Test Definition File"

Notes string

Mission string Value: "Swarm"

Should correspond with the Mission
element of the file name

File_Class string Should equal the File Class element of the

file name
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Format: Any 4 character value.

File_Type string Size: 10 bytes
Value: "AUX_PAR_QC"
Validity_Period structure See Validity_Period definition
File_Version integer Size: 4
Format: "0001"
Should start at 1 (not 0)
Should equal the File Version element of
the file name
Source structure See Source definition
Table 7 Validity _Period
Tag name Type Attributes Description
Validity_Start string Value: "UTC=0000-00-00T00:00:00"
Validity_Stop string Value: "UTC=9999-99-99T799:99:99"
Table 8 Source
Tag name Type Attributes Description
System string Value: "DQC"
Creator string Value: "DQC"
Creator_Version string Value: "01.00"
Creation_Date string Size: 23 bytes
Format: "UTC=2001-01-01T00:00:00"
Should equal the creation time of the file
Table 9 Variable _Header
Tag name Type Attributes Description
Max_Error integer Maximum number of error messages that
the DQC should show per product file. The
value 0 indicates that there is no limit.
Max_Warning integer Maximum number of warning messages
that the DQC should show per product file.
The value 0 indicates that there is no limit.
Max_Error_Per_Test integer Maximum number of error messages that

the DQC should show for a single named
test per product file. The value 0 indicates
that there is no limit.
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Max_Warning_Per_Test |integer Maximum number of warning messages
that the DQC should show for a single
named test per product file. The value 0
indicates that there is no limit.
Table 10 Data_Block
Tag name Type Attributes Description
List_of Named_Tests structure count See List_of _Named_Tests definition
List_of_Named_Cross_ |structure count See List_of Named_Cross_File_Tests
File_Tests definition
List_of_Test_Definitions |structure count See List_of Test_Definitions definition
Table 11 List_of Named_Tests
Tag name Type Attributes Description
Named_Test structure See Named_Test definition
Table 12 Named_Test
Tag name Type Attributes Description
Name string Name that uniquely identifies this test.
Description string Optional description. This information will
be included in the log message when the
test fails.
Criticality string Indicates the severity of failure if this test
fails. Valid values are "Error" and
"Warning".
Test_Expression string CODA boolean expression (see [CODA]). If

the expression evaluates to False, the test
failed.

Table 13 List_of Named_Cross_File_Tests

Tag name

Type

Attributes

Description

Named_Cross_File_Test

structure

See Named_Cross_File_Test definition

Table 14 Named_Cross_File_Test

Tag name Type Attributes Description
Name string Name that uniquely identifies this test.
Description string Optional description. This information will

be included in the log message when the
test fails.
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Criticality

string

Indicates the severity of failure if this test
fails. Valid values are "Error" and
"Warning".

Value_Expression_Dbl

string

CODA expression (see [CODA]) that
returns the value for the data block file
that needs to be compared.

Value_Expression_Hdr

string

CODA expression (see [CODA]) that
returns the value for the header file that
needs to be compared.

Table 15 List_of _Test_Definitions

Tag name

Type

Attributes

Description

Test_Definition

structure

See Test_Definition definition

Table 16 Test_Definition

Tag name

Type

Attributes

Description

Product_Type

string

Name of the product type to which this
test definition applies. A combination of
product type and product format version
(see below) uniquely identifies the test
definition that should be used. Header and
Datablock files are treated as separate
'products' in order to assign separate tests
for each file. To this end the product type
of a .HDR file is the product type of the
.DBL file appended with _HDR.

Format_Version

integer

The product format version number (This
number corresponds to the product
version number as returned by the CODA
software for the product).

List_of Tests

structure

count

See List_of_Tests definition.

List_of _Named_Test_R
eferences

structure

count

See List_of Named_Test_References
definition.

List_of Cross_File_Test
S

structure

count

See List_of Cross_File_Tests definition.
(this list will be empty for HDR and EEF
product file test definitions)

List_of Named_Cross_
File_Test_References

structure

count

See

List_of _Named_Cross_File_Test_Reference
s definition.

(this list will be empty for HDR and EEF
product file test definitions)

Table 17 List_of Tests

Tag name

Type

Attributes

Description
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Test

structure

See Test definition

Table 18 List_ of Named_Test References

Tag name

Type

Attributes

Description

Named_Test_Reference

structure

See Named_Test_Reference definition

Table 19 List_of Cross_File Tests

Tag name

Type

Attributes

Description

Cross_File_Test

structure

See Cross_File_Test definition

Table 20 List_of Named _Cross_File_Test_References

Tag name

Type

Attributes

Description

Named_Cross_File_Test|structure

See Named_Cross_File_Test_Reference

_Reference definition
Table 21 Test
Tag name Type Attributes Description

Path string Location in product hierarchy where this
test should be applied.

Name string Name of this test. The name is for
convenience and will be used in the test
report. It does not need to be unique but
it is recommended that it is descriptive
and unique in the scope of a
Test_Definition.

Description string Optional description. This information will
be included in the log message when the
test fails.

Criticality string See Criticality in Named_Test definition

Test_Expression string CODA boolean expression (see [CODA]). If
the expression evaluates to False, the test
failed.

Table 22 Named_Test_Reference

Tag name Type Attributes Description
Path string Location in product hierarchy where this
test should be applied.
Name string Cross reference to a Named_Test. The
value must be a Name of a Named_Test
defined in the List_of_Named_Tests.
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Table 23 Cross_File_Test

Tag name Type Attributes Description

Name string Name that uniquely identifies this test.

Description string Optional description. This information will
be included in the log message when the
test fails.

Criticality string Indicates the severity of failure if this test
fails. Valid values are "Error" and
"Warning".

Value_Expression_Dbl |string CODA expression (see [CODA]) that
returns the value for the data block file
that needs to be compared.

Value_Expression_Hdr |string CODA expression (see [CODA]) that
returns the value for the header file that
needs to be compared.

Table 24 Named_Cross_File_Test_Reference

Tag name Type Attributes Description

Name string Cross reference to a
Named_Cross_File_Test. The value must
be a Name of a Named_Cross_File_Test
defined in the

List_of Named_Cross_File_Tests.

3.4 Test Report

3.4.1 Description

The Test Report file contains the results of the product screening as performed by the DQC. The file
is in XML format and follows [FMT-GDL]. For the DQC processor the product type of the Test Report
file is determined from the the File_Type of the first Output entry in the JobOrder file. The product
type will take the format REPx_DQC__, where 'x' equals '_', 'A", 'B', or 'C'. For the standalone DQC,
the product type will always be AUX_REP_QC.

The filename of the Test Report file will be:

SW _<file class> <product type 1> <creation time> <product type
2><product start time>.EEF

If the DQC is run in standalone mode the file class will always be MANU. If the DQC is run in
processor mode, the file class is taken from the value of the (mandatory) 'File_Class' dynamic
processing parameter in the Job Order file.

Product type 1 is the product type of the DQC report (REP__DQC__, REPA_DQC__, REPB_DQC__,
REPC_DQC__, or AUX_REP_QCQC).

The creation time is the creation time of the file in yyyymmddThhmmss format.

The second product type is the product type of the file that was checked.
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The product start time is the start time of a product (or validity start time for auxiliary products) in
yyyymmddThhmmss format.

An example of a real filename is:

SW_OPER _REPA DQC 20100901T000000_MAGA HR 1B20080704T104509.EEF

3.4.2 Format
Table 25 Test Report file
Tag name Type Attributes Description
Earth_Explorer_File structure See Earth_Explorer_File definition

Table 26 Earth_Explorer_File

Tag name Type Attributes Description
Earth_Explorer_Header |structure See Earth_Explorer_Header definition
Data_Block structure type="xml" See Data_Block definition

Table 27 Earth_Explorer_Header

Tag name Type Attributes Description
Fixed_Header structure See Fixed_Header definition
Variable_Header structure See Variable_Header definition

Table 28 Fixed_Header

Tag name Type Attributes Description

File_Name string Format:
"SW__ccCC_XxXXXXXxXxxx_yyyymmddThhmm
ss_ppppppppppyyyymmddThhmmss"

File_Description string Value: "APPROVE Test Report File"

Notes string Will contain the name and version of the
approve executable if (and only if) the
DQC is run in processor mode.

Format: "APPROVE 1.0"

Mission string Value: "Swarm"

Should correspond with the Mission
element of the file name

File_Class string Value: Taken from the File_Class dynamic

processing parameter from the Job Order
file.
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Format: Any 4 character value

For the standalone DQC this field will be
set to "MANU".

File_Type string Size: 10 bytes
For the DQC processor this field will be
equal to the value of File_Type of the first
Output entry in the Job Order file.

For the standalone DQC this field will be
set to "AUX_REP_QC".

Validity_Period structure See Validity_Period definition

File_Version integer Value: Taken from the File_Counter
dynamic processing parameter from the
Job Order file.

For the standalone DQC this field will be
set to "0001".
Source structure See Source definition
Table 29 Validity_Period
Tag name Type Attributes Description

Validity_Start string Format: "UTC=2000-01-01T00:00:00"
Will be equal to the Validity_Start field of
the screened product.

Validity_Stop string Format: "UTC=2000-01-01T00:00:00"
Will be equal to the Validity_Stop field of
the screened product.

Table 30 Source
Tag name Type Attributes Description

System string For the DQC processor this field will be
equal to the value of Processing_Station in
the Job Order file.

For the standalone DQC this field will be
set to 'Standalone’

Creator string For the DQC processor this field will be

equal to the value of Processor_Name in
the Job Order file.

For the standalone DQC this field will be
set to 'APPROVE'
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Creator_Version

string

For the DQC processor this field will be
equal to the value of Version in the Job
Order file.

For the standalone DQC this field will be
set to the software version of APPROVE
(e.g. "1.0")

Creation_Date

string

Size: 23 bytes
Format: "UTC=2001-01-01-T00:00:00"
Gives the creation time of the report file.

This should be equal to the creation time
element of the report file name.

Table 31 Variable_Header

Tag name

Type

Attributes

Description

Product

string

Name of the screened product (this is the
filename including extension). For a
product that was split in a separate header
and data block file, this field will contain
the name of the data block file.

Test_Definition_File

string

Product name of the Test Definition file
that was used (i.e. without path or
extension).

Format_Definition_File

string

File name of the CODA Product Format
Definition file that was used (without path,
but with extension).

Product_Quality

enum

Possible values:

'VALID_PRODUCT': no errors or warnings
were found in the product

'PRODUCT_HAS_ERRORS': the product
contained errors

'PRODUCT_HAS_WARNINGS': the product
contained warnings (but no errors)

Table 32 Data_Block

Tag name

Type

Attributes

Description

List_of Test _Modes

structure

count

See List_of_Test_Modes definition

Contains a list of the different Test Modes
that have been executed on a product.

List_of Messages

structure

count

See List_of Messages definition
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Table 33 List_of _Test_Modes

Tag name

Type

Attributes

Description

Test_Mode

enum

Possible values:

"STRUCTURE_SIZE_AND_READ": This test
performs a structural check of a file and
successfully tries to read each data
element from a file

"STRUCTURE_SIZE_AND_READ_HEADER":
The same test as
STRUCTURE_SIZE_AND_READ but
performed on the header file that belongs
to the screened file (if the screened file is
already a header file, then you will only
get STRUCTURE_SIZE_AND_READ)

"EXPRESSION": This test executes all tests
in the Test Definition File that are available
for the screened file.

"EXPRESSION_HDR": The same as
EXPRESSION but performed on the header
file (if the screened file is already a header
file, then you will only get EXPRESSION)

"DATA_HEADER_CROSS_CHECK": This
test executes all tests in the Test
Definition file that check consistency
between the data block and header file.

Table 34 List_of_Messages

Tag name

Type

Attributes

Description

Message

structure

See Message definition

Table 35 Message

Tag name

Type

Attributes

Description

Criticality

enum

Indicates the severity of failure. Valid
values are 'Error' and 'Warning'.

Test_Mode

enum

See Test_Mode field of List_of_Test_Modes
definition.

Indicates the test mode within which this
failed test falls. This field can be empty if
no test mode is applicable.

Notes

string

Message details. If the message was
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related to a failed test and a description
was provided for the test then the test
description will be included in this field.

Path string Location within the file where the failure
occurred. This field can be empty if no
path is applicable.

Name string Name of the test that produced this

message (name can be empty depending
on the value of Test_Mode).
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3.5 Job Order

3.5.1 Description

The Job Order file is generated by the Management Layer based on the contents of the Task Table
file and user input.

3.5.2 Format
The format of the Job Order file is described in [PDS-IPF-ICD].

The contents of the Job Order file should follow from the Task Table content as specified in [PDS-
IPF-ICD], with the exception of the specific values for the dynamic processing parameter variables.
The DQC requires the dynamic processing parameters with name "File_Class" and "File_Counter" to
be present in the Job Order file. The DQC will use their values as file class and file version
(respectively) for the Test Report and Product Report files.

Note that the Job Order file may not contain any CDATA sections, otherwise this will break the
generation of the Product Report (where the Job Order file is included inside a CDATA section).

An example Job Order file is given in Appendix B.
3.6 Command-line Parameters

3.6.1 Description

If the approve executable is run with the location of an IPF Job Order file as single command-line
parameter then the DQC will operate as a DQC processor. In all other cases (i.e. number of
parameters is not equal to 1 or the single parameter does not point to an IPF Job Order file) the
DQC will operate in the standalone DQC mode.

The approve application can be operated in the following ways:

Table 36 Command line parameters

Use case Description

approve <Job Order file> Runs approve as a DQC processor task. All configuration
information will be taken from the Job Order file.

approve [<options>] <files> |Run DQC as a standalone application. The product files whose file
locations are passed as parameter to approve will be screened.

approve -h, --help Provides a short description on stdout of the possible use cases
and applicable parameters for the approve application

approve -v, --version Write the name, version, and copyright information of the
executable to stdout

When run as a standalone application, approve supports the following options:

Table 37 APPROVE Standalone command line options
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Use case

Description

--report

Instead of writing test results to stdout, results will be written to a
Test Report file using the DQC processor Test Report format. Per
product a single Test Report file will be generated.

If this option is provided when checking DBL files, then approve
will also look for the accompanying HDR file and check that file
(including cross file checks). Otherwise HDR files are not checked
together with DBL files.

--test <Test Definition file>

By default approve will only apply its build-in checks on each of the
product files. With this parameter you can specify a Test Definition
file with additional tests that will be performed on the product files.
If both the --test parameter and the APPROVE_TEST_DEFINITION
environment variable are set, then the command-line parameter
will have precedence.

--stdout <Logging Level>

Overrides the logging default log level for messages sent to
standard output. Valid values are DEBUG, INFO, PROGRESS,
WARNING and ERROR.

--stderr <Logging Level>

Overrides the logging default log level for messages sent to
standard error. Valid values are DEBUG, INFO, PROGRESS,
WARNING and ERROR.

--errors <Max Number>

Overrides the Max_Error number specified in the Test Definition
File.

--warnings <Max Number>

Overrides the Max_Warning number specified in the Test Definition
File.

--errors-per-test <Max
Number>

Overrides the Max_Error_Per_Test number specified in the Test
Definition File.

--warnings-per-test <Max
Number>

Overrides the Max_Warning_Per_Test number specified in the Test
Definition File.

3.7 Environment variables

3.71

Environment variables are only applicable if the DQC is run in standalone mode. For the DQC in
processor mode the environment variable settings are overruled by the information in the Job Order
file.

Description

Table 38 Environment variables

Environment variable Description

APPROVE_TEST_DEFINITION |Set this environment variable to a full path to your test definition
file to have the DQC use that test definition file for screening
products. This environment variable can be overruled with the

--test command line parameter.

CODA_DEFINITION In order to run the DQC in standalone mode you will have to set

this environment variable and have it point (with a full path) to the
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Product Format Definition file. If this variable is not set the DQC
will not be able to recognise any products and give an
'unsupported' error for each product it is passed.

3.8 Logging

3.8.1 Description

The DQC will write log messages to stdout and stderr. The DQC processor will format its messages
according to [PDS-IPF-ICD]. The standalone DQC will use a different format for its log messages.

Log messages are categorized as DEBUG, INFO, PROGRESS, WARNING, and ERROR (in that order)
in line with [PDS-IPF-ICD]. For the DQC processor the minimum category of messages to be printed
can be controlled via the Management Layer (resulting in appropriate values for the
Stdout_Log_Level and Stderr_Log_Level fields in the job order file). For the standalone DQC the
default minimum category is WARNING for both stdout and stderr and this can be changed using
the --stdout and --stderr command line options.

An overview of log messages for the DQC can be found in the User Manual [DQC-SUM].

3.8.2 Format

The DQC processor log messages will contain the current date/time, the node name, the processor
name, the processor version, the PID, a header separator, the message type, and the message
text. An example is given below:

2006-09-01T12:00:00.000000 ipflwsl DQC MAGA HR 1B 02.01 [0000014711]: [I] starting screening of product

The Processor Name and Version are taken from the Processor_Name and Version fields of the Job
Order file. If there were problems with extracting the necessary information from the Job Order file
any error messages will be written with the name and version of the executable as values for
Processor Name and Version.

The log messages for the standalone DQC will be less verbose as that for the DQC processor. The
messages will be a subset of the messages that are produced by the DQC processor and only the
message text will be written to stdout/stderr. The message text will be prefixed by 'WARNING: ' or
'ERROR: ' in case of a warning or error condition.

3.9 Exit code

3.9.1 Description

The DQC processor and standalone DQC will use different exit codes.

The DQC processor will use the following exit codes:

Science and Technology B.V.
PO Box 608, 2600AP Delft, The Netherlands

www.stcorp.nl
37/53



sle|t

dependable solutions

Reference : ST-ESA-SWARM-ICD-0002
SWARM MPPF-CVQ Version :1.10 page

DQC Processor ICD Date : 18 Sep 2012 38/53

Table 39 DQC processor exit codes.

Exit code Description
0 The product screening was successful
128 An error occurred that was not related to the product format of the

test product.

If the DQC returns with exit code 128 then an error log message will have been written to stderr
indicating the cause of the error.

The standalone DQC will use the following exit codes:

Table 40 Standalone DQC exit codes.

Exit code

Description

0 No problems were found (neither in the operation of the DQC, nor
in the test products)

1 An error occurred that was not related to the product format of the
test product.

2 One or more errors were found in the test products. This exit code
will also be used if a product type or product format version was
not recognised or is not supported.

3 One or more warnings were found in the test products (but no

errors were found)

If the DQC returns with exit code 1 or higher then appropriate error/warning messages will have

been written to stderr.

Note that the DQC processor will return an exit code 0 even if the product contained
errors/warnings. The standalone DQC will return an exit code 2 or 3 in such cases.

3.10 Product List

3.10.1 Description

The Product List file will be an ASCII file containing the product filenames of the Test Report (i.e
without path, but with extension) and Product Report, each filename followed by a NewLine
character. The Product List file will be named <order_id>.LIST, where <order_id> is the order id
that was extracted from the Job Order filename.

3.10.2 Format

An example of the content of a Product List file is:

SW_OPER REPA_DQC___ 20100901T000000 MAGA HR 1B20080704T104509.EEF
SW_OPER_REPA_DQCRP_20100901T000000 MAGA HR_1B20080704T104509.EEF
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3.11 Product Report

3.11.1 Description

The Product Report file will be an XML file with the same format as the Product Report for the L1b
processor [L1B-PROCINT], containing all messages that were sent to the log file in XML format and
some additional information.

A Product Report will only be generated for the DQC in processor mode and only if the Job Order file
was successfully read (i.e. all required parameters that are needed to determine the Product Report
filename and header contents need to be available before the file can be produced).

The filename of the Product Report file will be:

SW <file class> <product type 1> <creation time> <product type
2><product start time>.EEF

Product type 1 is the product type of the product report (REP__DQCRP, REPA_DQCRP,
REPB_DQCRP, or REPC_DQCRP).

The file class and instance id of the filename will be the same as that of the Test Report file.
An example of a real filename is:
SW_OPER REPA DQCRP 20100901T000000 MAGA HR 1B20080704T104509.EEF

3.11.2 Format

The format of the Product Report file is defined in Section 4.5 of [L1B-PROCINT]. The Variable
Header will be empty and the Fixed Header will have the following contents:

Table 41 Fixed Header

Task Table element Value

File_Name Format:
"SW__cccc_xxxxxxxxxx_yyyymmddThhmmss
_zzzzzzzzzzyyyymmddThhmmss"

File_Description Value: "DQC Product Report File"
Notes

Mission Value: "Swarm"

File_Class Same as File_Class of Test Report File
File_Type This field will be equal to the value of

File_Type of the second Output entry in the
Job Order file.

Validity_Period Same as Validity_Period of Test Report File

File_Version Value: "0001" or taken from File_Counter
dynamic processing parameter from the Job
Order file.

Source Same as Source of Test Report File

The Data Block will have the following format:
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Table 42 Data_Block

Tag name Type Attributes Description
Product_Report structure See Product_Report definition
Table 43 Product_Report
Tag name Type Attributes Description
Processor_Name string Value: equal to the value of
Processor_Name in the Job Order file.
Processor_Version string Value: equal to the value of Version in the
Job Order file.
PID integer Equal to the system process id of the
APPROVE task
Date_Time_of_Operatio |structure See Date_Time_of_Operation definition
n
List_of Input_File_Nam |structure count See List_of Input_File_Names definition
es
List_of Output_File_Na |structure count See List_of Output_File_Names definition
mes
List_of_Messages structure count See List_of Messages definition
Synthetic_Exit_Code integer Value: "FAILURE" in case of a processing
error and "SUCCESS" in case the
screening of the product succeeded.
Job_Order This element contains the full contents of
the Job Order file encapsulated in a CDATA
section.
Table 44 Date_Time_of_Operation
Tag name Type Attributes Description
Start string Format: "UTC=2000-01-
01T00:00:00.000000"
Will be equal to the time of the first log
message in List_of Messages
Stop string Format: "UTC=2000-01-
01T00:00:00.000000"
Will be equal to the creation time of the
Product Report
Table 45 List_of_Input_File_Names
Tag name Type Attributes Description
File_Name string There will only be one 'File_Name' entry
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containing the filename of the product that
was screened (as referenced in the Job
Order file)

Table 46 List_of _Output_File_Names

Tag name Type Attributes Description
File_Name string There will be two 'File_Name' entries.
The first entry will contain the file name
(including path and extension) of the
generated Test Report.
The second entry will contain the file name
(including path and extension) of the
generated Product Report (i.e. this file).
Table 47 List_of_Messages
Tag name Type Attributes Description
Message struct See Message definition
Table 48 Message
Tag name Type Attributes Description
Date_Time string Format: "UTC=2000-01-
01T00:00:00.000000"
Generation time of log entry in UTC time
Type string Format: "[c]"
With 'c' being either 'D' (DEBUG), 'T'
(INFO), 'P' (PROGRESS), 'W' (WARNING),
or 'E' (ERROR).
Text string Contains the log message text. The text

will use xml entities &lt;, &gt;, and &amp;
to escape the xml reserved characters '<’,
'>', and '&' respectively.

3.12 Task Table

3.12.1

Description

This is a static file that specifies the executables that a processor is composed of and specifies
which input, output, and intermediate files are involved for each executable.

There will be one Task Table file per logical processor. This means that there is one Task Table file

per satellite.

The name of the Task Table file is the concatenation of 'TaskTable_ SWARM', the letter of the
satellite (A, B, or C), an '_', the name of the processor, which is DQC, and the '.xml' extension. The
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(e.g. TaskTable_ SWARMA_DQC.xml).
3.12.2 Format
The format of the Processor Task Table file is defined in [PDS-IPF-ICD].
The contents of the Task Table file will be filled as follows:

Table 49 Task Table File
Task Table element Value

Processor_Name

"DQC_<single character id of satellite>"

Version Current version of the DQC in "XX.YY" format
Test "No"

Min_Disk_Space "1024"

Max_Time "Q"

List_of_Cfg_Files

There will be 2 configuration files. The first entry
should describe the Product Format Definition file
and the second entry the Test Definition File.

.../Cfg_File[0]/Version

The last modification date of the CODA product
definition file for SWARM in YYYYMMDD format.

.../Cfg_File[0]/File_Name

The full path to the SWARM codadef file.
Example: "/usr/local/DCC-01.00/config/SWARM-
20090101.codadef"

.../Cfg_File[1]/Version

Version of the DQC Test Definition File
Example "0001"

.../Cfg_File[1]/File_Name

The full path to the DQC Test Definition File.
Example: /usr/local/DQC-
01.00/config/SW_OPER_AUX_PAR_QC_00000000TO
00000_99999999T999999_0001.EEF"

List_of Dyn_ProcParam

There will be 2 dynamic processing parameters.

../Dyn_ProcParam[0]/Param_Name "File_Class"
../Dyn_ProcParam[0]/Param_Type "String"
../Dyn_ProcParam[0]/Param_Default "OPER"

../Dyn_ProcParam[1]/Param_Name

"File_Counter"

../Dyn_ProcParam[1]/Param_Type

"Number"

../Dyn_ProcParam[1]/Param_Default

"0001"

List_of_Pools

There will only be one pool

Pool[0]/Detached

"false"

Pool[0]/Killing_Signal

"15" (SIGTERM)

Pool[0]/List_of Tasks

There will be 1 task

.../Task[0]/Name

"APPROVE"
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.../Task[0]/Version This value should be the same as the internal
version of the approve executable.
(run 'approve -V' to retrieve the version)
.../Task[0]/Critical "true"
.../Task[0]/Criticality_Level 2"

.../Task[0]/File_Name

Full path to the approve executable.
Example: "/usr/local/DQC-01.00/bin/approve"

.../Task[0]/List_of_Inputs

There will be 1 input to this task

.../Input[0]/Mode

"ALWAYS"

.../Input[0]/Mandatory

IlYesll

.../Input[0]/List_of Alternatives

There will be one entry for each product type for the
satellite that is covered by the tasktable file.

.../Alternative[...]/Order

IIOII

.../Alternative[...]/Origin "DB"
.../Alternative[...]/Retrieval_Mode "LatestValCover"
.../Alternative[...]/TO "o"
.../Alternativel[...]/T1 "o"

.../Alternative[...]/File_Type

File type of the file that this DQC processor is able to
screen.
Example: "MAGA_HR_1B"

.../Alternativel...]/File_Name_Type

This can be either "Stem" (in case of a dual-file
.DBL/.HDR product) or "Physical" (for single file
products).

In case of a dual-file .DBL/.HDR product (i.e.
File_Name_Type=Stem) the File_Name input
provided should be the product filename without the
filename extension. The DQC will then find the
header and datablock files for the product by
appending the .DBL and .HDR extension to the
filename.

If File_Name_Type is Physical a reference to the full
filename (including extension) should be provided
and the product should consist of only a single file.

.../Task[0]/List_of_Outputs

There will be 2 outputs: The first output should
describe the Test Report File and the second output
the Product Report File.

.../Output[0]/Destination

IIDBII

.../Output[0]/Mandatory

IlYesll

.../Output[0]/File_Type

The product type of the report depends on the type
of the product that this processor can screen and is
one of "REP__DQC__", "REPA_DQC__",
"REPB_DQC__", or "REPC_DQC__".

.../Output[0]/File_Name_Type

"Directory"

.../Output[1]/Destination

IlDBll
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.../Output[1]/Mandatory "Yes"

.../Output[1]/File_Type The product type of the report depends on the type
of the product that this processor can screen and is
one of "REP__DQCRP", "REPA_DQCRP",
"REPB_DQCRP", or "REPC_DQCRP".

.../Output[1]/File_Name_Type "Directory"

.../Task[0]/List_of Breakpoints This list will be empty (i.e. count="0")

An example Task Table file can be found in Appendix A.
3.13 Workstation Configuration File

3.13.1 Description

The Workstation Configuration file defines the full list of processors for an IPF. For the DQC there
will be one logical processor per satellite. For each logical processor an entry has to be added to the
Workstation Configuration file.

The name of a DQC processor is the concatenation of the name 'DQC', an underscore '_', and the
single-character indicator of the satellite. For instance, the processor that will screen products for
Satellite A will be named DQC_A.

3.13.2 Format
The format of the Workstation Configuration file is described in [PDS-IPF-ICD].

An example <Processor> fragment of the Workstation Configuration file for the DQC for satellite A
is provided below:

<Processor>
<Processor Name>DQC_A</Processor_Name>
<Version>01.00</Version>
<Log Level>INFO</Log Level>
<Stdout_Log Level>DEFAULT</Stdout Log Level>
<Stderr Log Level>DEFAULT</Stderr Log Level>
<Task_Table>/usr/acs/processors/DQC-01.00/config/TaskTable SWARMA DQC.xml</Task_Table>
<List of Orders count="3">
<Order>
<Order Type>Systematic</Order Type>
<Status>enabled</Status>
</Order>
<Order>
<Order_ Type>Reprocessing</Order_ Type>
<Status>enabled</Status>
</Order>
<Order>
<Order Type>Backlog Processing</Order Type>
<Status>enabled</Status>
</Order>
</List_of Orders>
</Processor>
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4 Data Exchange

All data exchange from and to the DQC when the DQC is operated in processor mode is handled by
the Management Layer software (see [PDS-IPF-ICD]). Files will be provided to the DQC in a working
directory and the DQC will store all generated files in this directory as well.

For the DQC in standalone mode the user will be responsible for making all required input files
available on the host machine and providing the proper paths to these files using the command line
options of the approve executable. If a report is generated then this file will be saved to the location
as indicated by the '--report' command line option. The user will be responsible for further handling
of this file.

5 Data Volumes

This section details the information needed to calculate estimates for the volume of data that is
provided as input to the DQC and the amount of data that the DQC produces.

5.1 Input Product Files

The volume of input products depends on the configuration of the platform on which the DQC
operates. It can be calculated based on the PDGS System Budget information as provided in [PDGS-
ICD] and filtering on the list of supported product type for the platform as provided in Table 2 of
this document.

5.2 Test Definition Files

There will be one Test Definition Files per platform. It's size depends on the amount of tests that
are defined for each of the products, but is roughly in the order of a few 100KB to 1MB.

5.3 Test Report

The amount of test reports produced by the DQC depends on the amount of product files that a
platform will perform quality control on. Indicative amounts for these numbers can be found in
[PDGS-ICD]. The size of a report for a product depends on the amount of errors/warnings that the
DQC has found. The minimum size of a report (in case no issues were found) is 1.5KB. The
maximum size can be controlled using the Max_Error, Max_Warning, Max_Error_Per_Test, and
Max_Warning_Per_Test parameters in the Test Definition file. Each message takes about 250 bytes
(depending on the size of the description/path/etc. information). The total file size can thus be
roughly estimated using the formula: 1500 + 250 x (num_errors + num_warnings) bytes.

5.4 Product Report

The data volume rules for Product Reports are similar to that of Test Reports. However, the
estimate for the total file size is slightly different. The minimum size of a report is about 7KB but
the size of each product error/warning message is still about 250 bytes. So a rough estimate of the
total file size for a Product Report is: 7000 + 250 x (num_errors + num_warnings) bytes.
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Appendix A Example Task Table File

Note that this example only contains definitions for 3 different kinds of input product types. The real
Task Table file will list all possible product types for a satellite in the List_of Alternatives section of
the Input.

<?xml version="1.0" 2>
<Ipf_ Task Table xmlns:xsi="http://www.w3.0rg/2001/XMLSchema-instance"
xsi:noNamespaceSchemalocation="TaskTable.xsd">
<Processor Name>DQC A</Processor Name>
<Version>01.00</Version>
<Test>No</Test>
<Min_Disk_Space>1024</Min Disk Space>
<Max_Time>0</Max Time>
<List_of Cfg Files count="2">
<Cfg File>
<Version>20090101</Version>
<File_Name>/usr/local/DQC-01.00/config/SWARM-20090101.codadef</File Name>
</Cfg_File>
<Cfg_File>
<Version>0001</Version>
<File Name>/usr/local/DQC-
01.00/config/SW_OPER AUX PAR QC 00000000T000000_99999999T999999 0001.EEF</File Name>
</Cfg_File>
</List_of Cfg Files>
<List of Dyn ProcParam count="2">
<Dyn_ProcParam>
<Param Name>File Class</Param Name>
<Param Type>String</Param Type>
<Param Default>OPER</Param Default>
</Dyn_ProcParam>
<Dyn_ProcParam>
<Param Name>File Counter</Param Name>
<Param Type>Number</Param Type>
<Param Default>0001</Param Default>
</Dyn_ProcParam>
</List_of Dyn ProcParam>
<List of Pools count="1">
<Pool>
<Detached>false</Detached>
<Killing Signal>15</Killing Signal>
<List_of Tasks count="1">
<Task>
<Name>APPROVE</Name>
<Version>1.0</Version>
<Critical>true</Critical>
<Criticality Level>2</Criticality Level>
<File Name>/usr/local/DQC-01.00/bin/approve</File Name>
<List_of Inputs count="1">
<Input>
<Mode>ALWAYS</Mode>
<Mandatory>yes</Mandatory>
<List of Alternatives count="3">
<Alternative>
<Order>0</Order>
<Origin>DB</Origin>
<Retrieval Mode>LatestValCover</Retrieval Mode>
<TO units="sec">0</T0>
<T1l units="sec">0</T1>
<File Type>ACCANOM 0 </File Type>
<File Name_ Type>Stem</File Name_ Type>
</Alternative>
<Alternative>
<Order>0</Order>
<Origin>DB</Origin>
<Retrieval Mode>LatestValCover</Retrieval Mode>
<TO units="sec">0</T0>
<T1l units="sec">0</T1>
<File Type>MAGA HR 1B</File Type>
<File Name Type>Stem</File Name Type>
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</Alternative>
<Alternative>
<Order>0</Order>
<Origin>DB</Origin>
<Retrieval Mode>LatestValCover</Retrieval Mode>
<T0 units="sec">0</T0>
<T1 units="sec">0</T1>
<File Type>MAGAEUL_1B</File Type>
<File Name Type>Physical</File Name Type>
</Alternative>
</List_of_ Alternatives>
</Input>
</List_of_ Inputs>
<List of Outputs count="2">
<Output>
<Destination>DB</Destination>
<Mandatory>Yes</Mandatory>
<Type>REPA DQC </Type>
<File Name Type>Directory</File Name Type>
</Output>
<Output>
<Destination>DB</Destination>
<Mandatory>Yes</Mandatory>
<Type>REPA DQCRP</Type>
<File Name Type>Directory</File Name Type>
</Output>
</List_of Outputs>
<List_of Breakpoints count="0">
</List_of Breakpoints>
</Task>
</List_of_ Tasks>
</Pool>
</List_of_ Pools>
</Task Table>
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Appendix B Example Job Order File

<?xml version="1.0" 2>
<Ipf Job Order xmlns:xsi="http://www.w3.0rg/2001/XMLSchema-instance"
xsi:noNamespaceSchemaLocation="JobOrder.xsd">
<Ipf Conf>
<Processor Name>DQC A</Processor Name>
<Version>01.00</Version>
<Stdout_ Log Level>INFO</Stdout Log Level>
<Stderr_Log Level>INFO</Stderr Log Level>
<Test>false</Test>
<Breakpoint Enable>true</Breakpoint Enable>
<Acquisition_Station>PDS</Acquisition_Station>
<Processing Station>PDS</Processing Station>
<Config_Files>
<Conf File Name>/usr/local/DQC-1.0/config/SWARM-20090101.codadef</Conf File Name>
<Conf File Name>/usr/local/DQC-
01.00/config/SW_OPER AUX PAR QC 00000000T000000_99999999T999999 0001.EEF</Conf File Name>
</Config Files>
<Sensing_ Time>
<Start>20090704 103655123456</Start>
<Stop>20090704_103655123456</Stop>
</Sensing Time>
<Dynamic Processing Parameters>
<Processing Parameter>
<Name>File Class</Name>
<Value>OPER</Value>
</Processing Parameter>
<Processing Parameter>
<Name>File Counter</Name>
<Value>0001</Value>
</Processing Parameter>
</Dynamic_Processing_ Parameters>
</Ipf Conf>
<List_of Ipf Procs count="1">
<Ipf Proc>
<Task_Name>APPROVE</Task_Name>
<Task Version>1.0</Task Version>
<Breakpoint>
<List of Brk Files count="0">
</List_of Brk Files>
</Breakpoint>
<List of Inputs count="1">
<Input>
<File Type>MAGA HR 1B</File Type>
<File Name Type>Stem</File Name Type>
<List_of File Names count="1">
<File Name>/SOMEPATH/SW OPER MAGA HR 1B 20090704T103655 20090704T104509 0001</File Name>
</List_of_ File_Names>
<List_of Time Intervals count="1">
<Time_ Interval>
<Start>20040704 103655123456</Start>
<Stop>20040704 103655123456</Stop>
<File Name>/SOMEPATH/SW_OPER MAGA HR 1B 20090704T103655 20090704T104509 0001</File Name>
</Time_Interval>
</List_of Time Intervals>
</Input>
</List_of Inputs>
<List_of Outputs count="2">
<Output>
<File Type>REPA DQC </File Type>
<File Name Type>Directory</File Name Type>
<File Name>/SOMEPATH/</File Name>
</Output>
<Output>
<File Type>REPA DQCRP</File Type>
<File Name Type>Directory</File Name Type>
<File Name>/SOMEPATH/</File Name>
</Output>
</List_of Outputs>
</Ipf_Proc>
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</List_of_ Ipf Procs>
</Ipf Job Order>
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Appendix C Example Test Report File

<?xml version="1.0" 2>
<Earth Explorer File>
<Earth Explorer Header>
<Fixed Header>
<File Name>SW OPER REPA DQC  20090513T113051 MAGA HR 1B20090704T103655</File Name>
<File Description>APPROVE Test Report File</File Description>
<Notes>APPROVE 1.0</Notes>
<Mission>Swarm</Mission>
<File Class>OPER</File Class>
<File Type>REPA DQC </File Type>
<Validity_Period>
<Validity Start>UTC=2009-07-04T10:36:55</Validity Start>
<Validity Stop>UTC=2009-07-04T10:45:09</Validity_ Stop>
</Validity Period>
<File Version>0001</File Version>
<Source>
<System>PDS</System>
<Creator>DQC_A</Creator>
<Creator Version>01.00</Creator Version>
<Creation_ Date>UTC=2009-05-13T11:30:51</Creation_Date>
</Source>
</Fixed_Header>
<Variable_ Header>
<Product>SW OPER MAGA HR 1B 20090704T103655 20090704T104509 0001</Product>
<Test_Definition File>SW TEST AUX PAR QC 00000000T000000_99999999T999999 0001</Test Definition File>
<Format Definition File>SWARM-20090101.codadef</Format Definition File>
<Product Quality>PRODUCT HAS ERRORS</Product Quality>
</Variable Header>
</Earth_Explorer Header>
<Data_Block type="xml">
<List of Test Modes count="1">
<Test_Mode>STRUCTURE_SIZE_AND_READ</Test Mode>
<Test Mode>STRUCTURE SIZE AND READ HEADER</Test Mode>
<Test Mode>EXPRESSION</Test Mode>
<Test_Mode>EXPRESSION_HEADER</TeSt_MOde>
</List_of Test Modes>
<List_of Messages count="1">
<Message>
<Criticality>ERROR</Criticality>
<Test_MOde>EXPRESSION_HEADER</TeSt_MOde>
<Notes>test failed (The file class does not match any of the predefined values); actual value =
'')</Notes>
<Path>/Earth explorer Header/Fixed Header/File Class</Path>
<Name>RangeFileClass</Name>
</Message>
</List_of_ Messages>
</Data_Block>
</Earth_Explorer File>
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Appendix D Example Product Report File

<?xml version="1.0" 2>
<Earth Explorer File>
<Earth Explorer Header>
<Fixed Header>
<File Name>SW OPER REPA DQCRP 20090513T113051 MAGA HR 1B20090704T103655</File Name>
<File Description>APPROVE Product Report File</File Description>
<Notes>APPROVE 1.0</Notes>
<Mission>Swarm</Mission>
<File Class>OPER</File Class>
<File Type>REPA DQCRP</File Type>
<Validity_Period>
<Validity Start>UTC=2009-07-04T10:36:55</Validity Start>
<Validity Stop>UTC=2009-07-04T10:45:09</Validity_ Stop>
</Validity Period>
<File Version>0001</File Version>
<Source>
<System>DQC</System>
<Creator>DQC_A</Creator>
<Creator Version>01.00</Creator Version>
<Creation_ Date>UTC=2009-05-13T11:30:51</Creation_Date>
</Source>
</Fixed_Header>
<Variable Header></Variable_ Header>
</Earth_Explorer_ Header>
<Data_Block type="xml">
<Product Report>

<Processor_ Name>DQC A</Processor Name>
<Processor Version>01.00</Processor Version>
<PID>39115</PID>
<Date Time of Operation>
<Start>UTC=2009-05-13T11:30:51.049913</Start>
<Stop>UTC=2009-05-13T11:30:51.073318</Stop>
</Date_Time_of Operation>
<List_of Input File Names count="1">
<File Name>/SOMEPATH/SW OPER MAGA HR 1B 20090704T103655 20090704T104509 0001</File Name>
</List_of Input File Names>
<List of Output File Names count="2">
<File Name>./SW_OPER REPA DQC_ 20090513T113051 MAGA HR 1B20090704T103655.EEF</File Name>
<File Name>./SW_OPER_REPA DQCRP_20090513T113051 MAGA HR 1B20090704T103655.EEF</File Name>
</List_of Output File Names>
<List_of Messages count="13">
<Message><Date Time>2009-05-13T11:30:51.049913</Date Time><Type>I</Type><Text>processor starting
(DQC_MAGA_HR_ 1B 01.00, APPROVE 1.0, CODA 1.0)</Text></Message>
<Message><Date Time>2009-05-13T11:30:51.049957</Date Time><Type>I</Type><Text>input Job Order file
is JobOrder.0.xml</Text></Message>
<Message><Date Time>2009-05-13T11:30:51.049997</Date Time><Type>I</Type><Text>input CODA definition
file is ../config/SWARM-20090402.codadef</Text></Message>
<Message><Date Time>2009-05-13T11:30:51.050063</Date_ Time><Type>I</Type><Text>input Test Definition
file is SW _TEST AUX PAR QC 00000000T000000 99999999T999999 0001.EEF</Text></Message>
<Message><Date Time>2009-05-13T11:30:51.050096</Date Time><Type>I</Type><Text>input Product file is
SW_OPER_MAGA HR 1B 20090704T103655 20090704T104509 0001</Text></Message>
<Message><Date Time>2009-05-13T11:30:51.055001</Date Time><Type>I</Type><Text>starting screening of
product</Text></Message>
<Message><Date Time>2009-05-13T11:30:51.061311</Date Time><Type>I</Type><Text>finished screening of
product</Text></Message>
<Message><Date Time>2009-05-13T11:30:51.065001</Date Time><Type>I</Type><Text>starting screening of
header file</Text></Message>
<Message><Date Time>2009-05-13T11:30:51.071165</Date Time><Type>E</Type><Text>test failed (The file
class does not match any of the predefined values); actual value = '') for test 'RangeFileClass' at
/Earth_explorer Header/Fixed Header/File Class</Text></Message>
<Message><Date Time>2009-05-13T11:30:51.071311</Date Time><Type>I</Type><Text>finished screening of
header file</Text></Message>
<Message><Date Time>2009-05-13T11:30:51.072384</Date Time><Type>I</Type><Text>product has
errors</Text></Message>
<Message><Date Time>2009-05-13T11:30:51.072452</Date_Time><Type>I</Type><Text>output Test Report is
./SW_OPER REPA DQC  20090513T113051 AUX PAR QC00000000T000000.EEF</Text></Message>
<Message><Date Time>2009-05-13T11:30:51.072739</Date_Time><Type>I</Type><Text>created test report
'./SW_OPER _REPA DQC__ 20090513T113051 AUX_ PAR_QC00000000T000000.EEF'</Text></Message>
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<Message><Date Time>2009-05-13T11:30:51.072929</Date_Time><Type>I</Type><Text>added
'SW OPER REPA DQC  20090513T113051 AUX PAR QC00000000T000000.EEF' to list file '0.LIST'</Text></Message>
<Message><Date Time>2009-05-13T11:30:51.073306</Date Time><Type>I</Type><Text>processor stopping,
exit code is 0 (SUCCESS), product screened</Text></Message>
</List_of Messages>
<Synthetic_ Exit Code>SUCCESS</Synthetic Exit Code>
<Job Order>
<! [CDATA[<?xml version="1.0" ?>
<Ipf Job Order xmlns:xsi="http://www.w3.0rg/2001/XMLSchema-instance"
xsi:noNamespaceSchemaLocation="JobOrder.xsd">
<Ipf Conf>
<Processor Name>DQC A</Processor Name>
<Version>01.00</Version>
<Stdout Log Level>INFO</Stdout Log Level>
<Stderr Log Level>INFO</Stderr Log Level>
<Test>false</Test>
<Breakpoint Enable>true</Breakpoint Enable>
<Acquisition_Station>PDS</Acquisition_Station>
<Processing Station>PDS</Processing Station>
<Config Files>
<Conf File Name>/usr/local/DQC-1.0/config/SWARM-20090101.codadef</Conf File Name>
<Conf File Name>/usr/local/DQC-
01.00/config/SW_OPER AUX PAR QC 00000000T000000_99999999T999999 0001.EEF</Conf File Name>
</Config Files>
<Sensing_Time>
<Start>20090704 103655123456</Start>
<Stop>20090704 103655123456</Stop>
</Sensing Time>
<Dynamic Processing Parameters>
<Processing Parameter>
<Name>File Class</Name>
<Value>OPER</Value>
</Processing Parameter>
<Processing Parameter>
<Name>File Counter</Name>
<Value>0001</Value>
</Processing Parameter>
</Dynamic Processing Parameters>
</Ipf Conf>
<List_of Ipf Procs count="1">
<Ipf Proc>
<Task_Name>APPROVE</Task_Name>
<Task Version>1.0</Task Version>
<Breakpoint>
<List_of Brk Files count="0">
</List_of Brk Files>
</Breakpoint>
<List of Inputs count="1">
<Input>
<File Type>MAGA HR 1B</File Type>
<File Name Type>Stem</File Name Type>
<List_of File Names count="1">
<File Name>/SOMEPATH/SW OPER MAGA HR 1B 20090704T103655 20090704T104509 0001</File Name>
</List_of_ File_Names>
<List_of Time Intervals count="1">
<Time_ Interval>
<Start>20040704 103655123456</Start>
<Stop>20040704 103655123456</Stop>
<File Name>/SOMEPATH/SW_OPER MAGA HR 1B 20090704T103655 20090704T104509 0001</File Name>
</Time_Interval>
</List_of Time Intervals>
</Input>
</List_of Inputs>
<List_of Outputs count="2">
<Output>
<File Type>REPA DQC_</File Type>
<File Name Type>Directory</File Name Type>
<File Name>/SOMEPATH/</File Name>
</Output>
<Output>
<File Type>REPA DQCRP</File Type>
<File Name Type>Directory</File Name Type>
<File Name>/SOMEPATH/</File Name>
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</Output>
</List of Outputs>
</Ipf Proc>
</List_of Ipf Procs>
</Ipf_ Job_Order>
11>
</Job_Order>
</Product_ Report>
</Data_Block>
</Earth_Explorer File>
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